User Tag List

Informational! Informational!:  0
Likes Likes:  0
Page 3 of 4 FirstFirst 1234 LastLast
Results 17 to 24 of 30

Thread: Cactus/Euphorbia in need of some help.

  1. #17

    Join Date
    Jun 2011
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Been away for awhile myself. Cactus is still with us, seems to be doing fine. I haven't noticed the white dots lately, so I think it's OK?

  2. #18

    Join Date
    Jun 2011
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well, it's doing much worse now. I haven't been watering it as much, and it's just..withering, yellow and brown all over. Parts of it feel soft. I don't think it's going to make it. I was going to post photos, but Flickr is banned at work.

    I might try taking some cuttings so I can still have something to remember this awesome plant by--but my last cutting didn't make it. Any tips?

  3. #19

    Join Date
    Nov 2010
    Location
    Mermentau, Louisiana
    Posts
    51
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmm....Im at a lose of words. A pic would help. How often are you watering the plant? Let it go completely dry in between watering. When you take a cutting are you taking the new "branch"? Let the cutting dry for about three days then plant. Is it outside? Inside? Alot of sun?

  4. #20

    Join Date
    Jun 2011
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Cactus by jebbewocky, on Flickr

    Inside, near the porch sun-door. Outside is too cold, and when I had it out before something took a BITE out of it! D: I let it dry completely out--I took my hand down into the dirt a ways and it was powder-dry. I haven't taking any deliberate cuttings so far, just pruned a few particularly pathetic parts.

  5. #21

    Join Date
    Nov 2010
    Location
    Mermentau, Louisiana
    Posts
    51
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmm.....o.k. A couple of things seem wrong in my opinion. Because of the yellowing then shriveling up, could be the roots are rotten. If the roots are o.k. I would up the watering to where the soil doesn't quite dries out. You say its cold outside...how cold? Is it in an area that gets dry heat blown on it like from a vent?

  6. #22

    Join Date
    Jun 2011
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Joel143 View Post
    Hmm.....o.k. A couple of things seem wrong in my opinion. Because of the yellowing then shriveling up, could be the roots are rotten. If the roots are o.k. I would up the watering to where the soil doesn't quite dries out. You say its cold outside...how cold? Is it in an area that gets dry heat blown on it like from a vent?
    The area is no drier than the rest of the apartment.
    It's getting to be fall here, so I'm wary of putting it out, despite our current 70-80 degree weather--and last time it got munched and had white stuff on it.

    I'll check the roots tonight--hopefully I've underwatered it somehow. I'm really lost on it--it was doing much better before the re-pot and soil transfer.

    EDIT: and the stem is like a deep brown--really looks like rot to me, based on what happened last time.

  7. #23

    Join Date
    Nov 2010
    Location
    Mermentau, Louisiana
    Posts
    51
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Im sorry I can't be much help. Im at a lose here. I've mentioned all I can think of. Try and take cuttings from nice green growth to start new plant. Again sorry I can't be any help. I've only had something similar once but it was with a cactus not a euphorbia. All my cactus and euphorbia or outside. I don't do anything until I see the temp getting into the 50's.

  8. #24

    Join Date
    Jun 2011
    Posts
    79
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Joel143 View Post
    Im sorry I can't be much help. Im at a lose here. I've mentioned all I can think of. Try and take cuttings from nice green growth to start new plant. Again sorry I can't be any help. I've only had something similar once but it was with a cactus not a euphorbia. All my cactus and euphorbia or outside. I don't do anything until I see the temp getting into the 50's.
    At this point I don't think there's much anyone can do.
    I don't know if maybe somehow the soil is bad? But it's just Miracle Gro cactus Mix, and I can't see anything in the soil making an impact this quick--that seems like something that would take a long time to show up. Plus, my mom uses MG all the time--I know it's not popular for carnivorous plants--but I can't see a euphorbia, a hardier plant having this bad of a time w/soil.

    I'll just try taking some cuttings and hope for the best.

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •