User Tag List

Informational! Informational!:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Lithops help

  1. #1
    shadow_walker
    Guest

    Wink

    I've got a pot of lithops here at work and they are slowly dying one by one. It seems to starts at the bottom of the plant. It looks like the the base of the lithops is rotting. The plant will turn to mush and then shrivel up to nothing.

    I used to water them once per week. I thought it was too much, so now I only water once every two or three weeks, and it is still happening....

    What is going on? I need help to keep the remaining ones alive.
    Thanks

  2. #2

    Join Date
    Jun 2002
    Location
    Illinois
    Posts
    302
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You're watering too much. Unless you have really low humidity, water once a month, or even less. From when they enter dormancy in the fall, until they start growing in the spring (after they fully emerge from the old leaves), don't water at all. Also, when you water, make sure it is only a little water. They'll almost never die from too little watering.

  3. #3

    Join Date
    Apr 2002
    Location
    Los Angeles, CA
    Posts
    809
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What I do is to give them a light spray from the mister every other day - 3 seconds on the constant mist (for me). The top layer is 1" of sand and it dries out in about an hour. The lithop roots barely get water that way, but I feel better about watering because I'm such the meddler!
    A flytrap ate my homework!
    -Michelle

  4. #4

    Join Date
    Jun 2002
    Posts
    1,272
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Talking

    Too much water! I water once every 2 mons... they're fine! [img]http://www.**********.com/iB_html/non-cgi/emoticons/smile.gif[/img] perhaps there are no drainage holes? It's best to water from bottom half an inch every 2 mons. Just my $0.02
    GOOD LUCK!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! [img]http://www.**********.com/iB_html/non-cgi/emoticons/smile.gif[/img] [img]http://www.**********.com/iB_html/non-cgi/emoticons/biggrin.gif[/img] [img]http://www.**********.com/iB_html/non-cgi/emoticons/tounge.gif[/img]
    I am back..

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •