User Tag List

Informational! Informational!:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Anybody Familiar With P0446 Evaporative Emission Control System Vent Control Circuit?

  1. #1
    Tropical Fish Enthusiast jimscott's Avatar
    Join Date
    Nov 2003
    Location
    Western New York
    Posts
    18,768
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Anybody Familiar With P0446 Evaporative Emission Control System Vent Control Circuit?

    My engine light is on. I took it to Autotune for a free diagnosis. They printed out 3 codes: 440, 441, 446. I already replaced the gas cap. My mechanic narrowed it down to P0446. Any ideas?

  2. #2
    Hello, I must be going... Not a Number's Avatar
    Join Date
    Nov 2006
    Location
    Los Angeles, CA
    Posts
    7,506
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Grand Hotel... always the same. People come, people go. Nothing ever happens.

  3. #3
    Admin- I'm growing CPs in the Desert of Tucson, Az. adnedarn's Avatar
    Join Date
    Jul 2001
    Location
    Tucson, Arizona USA
    Posts
    8,432
    Mentioned
    6 Post(s)
    Tagged
    1 Thread(s)
    If you search the internet by that code and your vehicle you'll likely find conversations on the "common" problem... For my truck (Dodge Dakota) it is the evap lines down by the valve under the drivers side by the gas tank tend to crack.
    Remember too, once the problem is solved, it takes a few cycles for the light to turn off... It's best to either have the code erased or disconnect the negative battery cable for a few mins to clear the code after you do something (like replace the gas cap) and see if the code comes back before moving on and assuming it's not corrected because the light is still on.
    -Andrew
    Owner of TerraForums, FlyTrapShop.com, and cpforums.org.
    Support FlyTrapShop, support TerraForums! www.flytrapshop.com

  4. #4
    Tropical Fish Enthusiast jimscott's Avatar
    Join Date
    Nov 2003
    Location
    Western New York
    Posts
    18,768
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    My mechanic turned the light off. I did a search, including NAN's link. I've got it narrowed down to the cannister, the hose, and evap vent valves. The cannister too expensive to replace but apparently, it can be cleaned. I really wish that if these lights came on because it detected something amiss, it would just tell us exactly what was amiss instead of listing a bunch of potential problems, leaving us with a guessing game and possibly replacing things didn't need to be replaced.

  5. #5
    Tropical Fish Enthusiast jimscott's Avatar
    Join Date
    Nov 2003
    Location
    Western New York
    Posts
    18,768
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    So I took my car to the repair shop, fearing the worst. It turns out that
    the light has been on because 2 sensors were rusted out. It was explained
    to me that in most normal cars, one could just buy replacement sensors. In
    my car, it’s part of a bigger and more expensive package. I have to replace
    the canister. The part is $451.50. Labor is $60. Toss the cost of the
    inspection, and the bottom line is $540. Also, my front brake pads are
    described as paper thin. It passes… but barely. They turned off the light
    and gave me a 10 day extension, and we’re going to see if the light stays
    off or not, before they order the parts. Trust me, the light will come on
    again. But at least it gives us some breathing room until next paycheck. We
    have to pay our rent with this paycheck. There isn’t enough to do both
    right now.

    This morning I stopped by the repair shop to tell them that the light was still off. The mechanic that actually worked on my car, yesterday, came out with his portatble computer and hooked it up to the car. Apparently, not all of the parameters have been reset yet, so he couldn't put an inspection sticker on yet. He said that I should drive it more and come back on Monday. I would bet anybody's bottom dollar that by then, the light will have come on. Either way, I wanna get this thing resolved, so I will have to fork over $540 anyways.

    I found this description on the Internet to describe what the mechanic was talking about:

    "Drive your vehicle for one week under normal driving conditions. During this period the emissions computer is gathering data and re-learning your vehicle's emissions components and systems. The emissions computer OBDII (on-board diagnostics) system must complete at least one drive cycle (in some cases two or three). A drive cycle is a sequence of internal tests which the emissions computer runs while your vehicle is being driven. This insures all emissions systems are functioning properly. Proper "readiness flags" are set as the computer completes it's cycles."

  6. #6
    Hello, I must be going... Not a Number's Avatar
    Join Date
    Nov 2006
    Location
    Los Angeles, CA
    Posts
    7,506
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    So this is for emissions inspection? Does NY have any sort of financial assistance on the repair for low income?
    Grand Hotel... always the same. People come, people go. Nothing ever happens.

  7. #7
    Tropical Fish Enthusiast jimscott's Avatar
    Join Date
    Nov 2003
    Location
    Western New York
    Posts
    18,768
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    They have assistance for home repairs, but not for cars. The way it was explained to me is that this engine light thing for emissions is relatively new. Emissions through leaky hoses or bad valves, etc... used to be vented to the atmosphere and we didn't know that anything was going on. Not anymore.

  8. #8
    Tropical Fish Enthusiast jimscott's Avatar
    Join Date
    Nov 2003
    Location
    Western New York
    Posts
    18,768
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Well, ~320 miles after the repair shop turned off the engine light... it came on again. I have no idea why the car went through its cycle to allow me to get through the inspction, and ~160 miles later, the light come back on again.. Strange.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •