User Tag List

Informational! Informational!:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Pc monitor died?

  1. #1
    Tropical Fish Enthusiast jimscott's Avatar
    Join Date
    Nov 2003
    Location
    Western New York
    Posts
    18,768
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    My home pc was making these clicking noises that sounded like static electricity, and then the screen went black.I tried the Degauss buttont to see if that would do anything, but it didn't. Do you think my monitor just quit? It is 6 years old.

  2. #2

    Join Date
    Jun 2005
    Location
    guelph
    Posts
    394
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sounds like it's pooped.
    I know a little about computers but have friends who know more. I was just talking to one on the phone and threw out this problem. Here's how he explained it... "Your computer moniter has a wire that runs down and connects to your motherboard . In some models this wire attaches very close to the motherboard's heat sink. This heat sink acts, unintentionally, as a capacitor over time. In old cpu's enough dust can build up to bridge this gap(between wire and sink) If enough voltage is stored in the heat sink it may leap to the motherboard near the moniter connection shorting/destroying your moniter."

    Sorry Jim,

    Zac
    "You can never underestimate the stupidity of the general public" -Scott Adams-

  3. #3
    nrbelex's Avatar
    Join Date
    Feb 2002
    Location
    New York
    Posts
    333
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    If you've checked all your connections and still nothing then I would have to agree that it's gone. At least montitors are a little bit cheaper than they used to be (especially CRT's).

    ~ Brett

  4. #4
    Tropical Fish Enthusiast jimscott's Avatar
    Join Date
    Nov 2003
    Location
    Western New York
    Posts
    18,768
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    So it appears that my tower possibly caused it? The green power light from the monitor still works. I just get no screen. I presume I will need to open up the tower and do some cleaning as well, just to make sure I don't have another set up for failure. Yes, at least it was the monitor and not the CPU. Thanx!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •